Posted by: sutrisno | July 10, 2009

Install Cacti di mandriva 2008

Kemarin saya mencoba mengistall cacti untuk monitoring network di dalam jaringan perusahaan saya….berikut langkah-langkahnya NB:aku install menggunakan Distro mandriva 2008
[itmtcon@kampret ~]$ su
Password:
[root@kampret itmtcon]# urpmi.addmedia main ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release with media_info/hdlist.cz
adding medium “main”
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release/media_info/synthesis.hdlist.cz
[root@kampret itmtcon]# urpmi.addmedia –update main_updates ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates with media_info/hdlist.cz
adding medium “main_updates”
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/media_info/synthesis.hdlist.cz
[root@kampret itmtcon]# urpmi.addmedia contrib ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release with media_info/hdlist.cz
adding medium “contrib”
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/media_info/synthesis.hdlist.cz
[root@kampret itmtcon]# urpmi.addmedia –update contrib_updates ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/updates with media_info/hdlist.cz
adding medium “contrib_updates”
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/updates/media_info/synthesis.hdlist.cz
[root@kampret itmtcon]# rpm -qa |grep graphviz
libgraphviz4-2.16.1-2mdv2008.1
graphviz-2.16.1-2mdv2008.1
libgraphviz-devel-2.16.1-2mdv2008.1
[root@kampret itmtcon]# rpm -qa |grep rrdtool
[root@kampret itmtcon]# rpm -qa |grep rrdcollect
[root@kampret itmtcon]# rpm -qa |grep rrdtool-tcl
[root@kampret itmtcon]# urpmi rrdtool
To satisfy dependencies, the following packages are going to be installed:
Package Version Release Arch
(medium “Mandriva Linux – 2008.1 (Powerpack) – Installer”)
rrdtool 1.2.27 1mdv2008.1 i586
(medium “main”)
librrdtool2 1.2.27 1mdv2008.1 i586
1.4MB of additional disk space will be used.
629KB of packages will be retrieved.
Proceed with the installation of the 2 packages? (Y/n) y
Please insert the medium named “Mandriva Linux – 2008.1 (Powerpack) – Installer”

installing librrdtool2-1.2.27-1mdv2008.1.i586.rpm rrdtool-1.2.27-1mdv2008.1.i586.rpm from /media/cdrom/i586/media/main
Preparing… #############################################
1/2: librrdtool2 #############################################
2/2: rrdtool #############################################
[root@kampret itmtcon]#
[root@kampret itmtcon]# rpm -qa |grep rrdtool
rrdtool-1.2.27-1mdv2008.1
librrdtool2-1.2.27-1mdv2008.1
[root@kampret itmtcon]# urpmi rrdcollect
No package named rrdcollect
[root@kampret itmtcon]# rpm -qa |grep rrdtool-tcl
[root@kampret itmtcon]# urpmi rrdtool-tcl
No package named rrdtool-tcl
[root@kampret itmtcon]# cd /home/itmtcon/Desktop/
[root@kampret Desktop]# ls
AdobeReader.desktop* rrdcollect-0.2-1.i386.rpm trash.desktop
Home.desktop subversion-1.5.4.tar.gz
media.desktop subversion-1.5.4.tar.gz.part
[root@kampret Desktop]# rpm -ivh rrdcollect-0.2-1.i386.rpm
Preparing… ########################################### [100%]
1:rrdcollect ########################################### [100%]
[root@kampret Desktop]# urpmi rrdtool-tcl
No package named rrdtool-tcl
[root@kampret Desktop]# cat /etc/is
issue issue.net
[root@kampret Desktop]# cat /etc/issue
Mandriva Linux release 2008.1 (Official) for i586
Kernel 2.6.24.4-desktop-1mnb on an i686 / \l
[root@kampret Desktop]# urpmi ntop
To satisfy dependencies, the following packages are going to be installed:
Package Version Release Arch
(medium “main”)
libpcap0 0.9.8 1mdv2008.1 i586
(medium “main_updates”)
libnet-snmp15 5.4.1 5.2mdv2008.1 i586
(medium “contrib”)
ntop 3.3 3mdv2008.1 i586
7.9MB of additional disk space will be used.
3.6MB of packages will be retrieved.
Proceed with the installation of the 3 packages? (Y/n) y

ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/libnet-snmp15-5.4.1-5.2mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/ntop-3.3-3mdv2008.1.i586.rpm
installing /var/cache/urpmi/rpms/ntop-3.3-3mdv2008.1.i586.rpm
/media/cdrom/i586/media/main/libpcap0-0.9.8-1mdv2008.1.i586.rpm
/var/cache/urpmi/rpms/libnet-snmp15-5.4.1-5.2mdv2008.1.i586.rpm
Preparing… #############################################
1/3: libnet-snmp15 #############################################
2/3: libpcap0 #############################################
3/3: ntop #############################################
———————————————————————-
More information on package ntop-3.3-3mdv2008.1.i586
There are some manual steps you need to do, first start /usr/sbin/ntop to set
the admin password, please consilte the docs/1STRUN.txt file for more info. After
that change directory to /etc/ntop and execute the makecert.sh script to
generate the ntop-cert.pem file.

Have fun!
———————————————————————-
[root@kampret Desktop]#
[root@kampret Desktop]# rpm -qa |grep mysql
perl-DBD-mysql-4.006-2mdv2008.1
libmysql15-5.0.51a-7mdv2008.1
[root@kampret Desktop]# rpm -qa |grep net-snmp-devel
[root@kampret Desktop]# urpmi mysql
To satisfy dependencies, the following packages are going to be installed:
Package Version Release Arch
(medium “main_updates”)
libmysql15 5.0.51a 8.1mdv2008.1 i586
mysql 5.0.51a 8.1mdv2008.1 i586
mysql-client 5.0.51a 8.1mdv2008.1 i586
mysql-common 5.0.51a 8.1mdv2008.1 i586
25MB of additional disk space will be used.
14MB of packages will be retrieved.
Proceed with the installation of the 4 packages? (Y/n) y

ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/upda
tes/libmysql15-5.0.51a-8.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/upda
tes/mysql-5.0.51a-8.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/upda
tes/mysql-client-5.0.51a-8.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/upda
tes/mysql-common-5.0.51a-8.1mdv2008.1.i586.rpm
installing mysql-5.0.51a-8.1mdv2008.1.i586.rpm libmysql15-5.0.51a-8.1mdv2008.1.i
586.rpm mysql-client-5.0.51a-8.1mdv2008.1.i586.rpm mysql-common-5.0.51a-8.1mdv20
08.1.i586.rpm from /var/cache/urpmi/rpms
Preparing… #############################################
1/4: libmysql15 #############################################
2/4: mysql-client #############################################
3/4: mysql-common #############################################
4/4: mysql #############################################
Warning: fuse is needed by mysqld in runlevel 2
Warning: fuse is needed by mysqld in runlevel 2
Warning: netfs is needed by mysqld in runlevel 2
Warning: netfs is needed by mysqld in runlevel 2
Warning: fuse is needed by mysqld in runlevel 2
Warning: fuse is needed by mysqld in runlevel 2
Warning: netfs is needed by mysqld in runlevel 2
Warning: netfs is needed by mysqld in runlevel 2
Warning: fuse is needed by mysqld in runlevel 2
Warning: fuse is needed by mysqld in runlevel 2
Warning: netfs is needed by mysqld in runlevel 2
Warning: netfs is needed by mysqld in runlevel 2
———————————————————————-
More information on package mysql-5.0.51a-8.1mdv2008.1.i586

The initscript used to start mysql has been reverted to use the one shipped
by MySQL AB. This means the following changes:

* The MYSQLD_OPTIONS=”–skip-networking” option in the /etc/sysconfig/mysqld
file has been removed, this is now set in the /etc/my.cnf file.

* The MySQL Instance Manager is used by default, set use_mysqld_safe=”1″ in
the /etc/sysconfig/mysqld file to use the old mysqld_safe script.

* The generation of the initial system mysql database is now done when mysql
is started from the initscript and only if the /var/lib/mysql/mysql
directory is empty (mysql_install_db). Previousely this was quite hidden and
silently done at (rpm) install time.

The extra MySQL-NDB server package has been merged into the MySQL-Max package
and ndb related pieces has been split into different sub packages as done by
MySQL AB. The MySQL libraries and the MySQL-common sub package uses the
MySQL-Max build so that no functionality required by for example the NDB
parts are lost.

The MySQL-common package now ships with a default /etc/my.cnf file that is
based on the my-medium.cnf file that comes with the source code. The
/etc/my.cnf file is constructed at build time of this package.

To connect to the Instance Manager you need to pass the correct command line
options like in the following examples:

* mysql -u root –password=my_password –port=2273 –protocol=TCP
* mysql -u root –password=my_password –socket=/var/lib/mysql/mysqlmanager.so ck

Please note you also need to add a user in the /etc/mysqlmanager.passwd file and
make sure the file is owned by the user under which the Instance Manager service
is running under.

———————————————————————-
[root@kampret Desktop]# urpmi net-snmp-devel
In order to satisfy the ‘devel(libsensors)’ dependency, one of the following pac kages is needed:
1- liblm_sensors3-devel-2.10.5-3mdv2008.1.i586: Development libraries and heade r files for lm_sensors (to install)
2- liblm_sensors-devel-3.0.1-1mdv2008.1.i586: Development libraries and header files for lm_sensors (to install)
What is your choice? (1-2) 2
In order to satisfy the ‘devel(libsysfs)’ dependency, one of the following packages is needed:
1- libsysfs-devel-2.1.0-8mnb1.i586: Headers for developing programs that will use sysfsutils (to install)
2- libsysfs1-devel-1.3.0-4mdv2008.0.i586: Headers for developing programs that will use sysfsutils1 (to install)
What is your choice? (1-2) 1
To satisfy dependencies, the following packages are going to be installed:
Package Version Release Arch
(medium “main”)
liblm_sensors3-devel 2.10.5 3mdv2008.1 i586
libsysfs-devel 2.1.0 8mnb1 i586
libwrap0-devel 7.6 33mdv2008.1 i586
(medium “main_updates”)
libnet-snmp-devel 5.4.1 5.2mdv2008.1 i586
(medium “contrib”)
liblm_sensors-devel 3.0.1 1mdv2008.1 i586
liblm_sensors4 3.0.1 1mdv2008.1 i586
1.6MB of additional disk space will be used.
967KB of packages will be retrieved.
Proceed with the installation of the 6 packages? (Y/n) y

ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release/libwrap0-devel-7.6-33mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release/libsysfs-devel-2.1.0-8mnb1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release/liblm_sensors3-devel-2.10.5-3mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/libnet-snmp-devel-5.4.1-5.2mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/liblm_sensors4-3.0.1-1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/liblm_sensors-devel-3.0.1-1mdv2008.1.i586.rpm
installing libwrap0-devel-7.6-33mdv2008.1.i586.rpm liblm_sensors4-3.0.1-1mdv2008.1.i586.rpm libsysfs-devel-2.1.0-8mnb1.i586.rpm libnet-snmp-devel-5.4.1-5.2mdv2008.1.i586.rpm liblm_sensors3-devel-2.10.5-3mdv2008.1.i586.rpm liblm_sensors-devel-3.0.1-1mdv2008.1.i586.rpm from /var/cache/urpmi/rpms
Preparing… #############################################
Installation failed:
file /usr/include/sensors/error.h conflicts between attempted installs of liblm_sensors-devel-3.0.1-1mdv2008.1.i586 and liblm_sensors3-devel-2.10.5-3mdv2008.1.i586
file /usr/include/sensors/sensors.h conflicts between attempted installs of liblm_sensors-devel-3.0.1-1mdv2008.1.i586 and liblm_sensors3-devel-2.10.5-3mdv2008.1.i586
file /usr/lib/libsensors.so conflicts between attempted installs of liblm_sensors-devel-3.0.1-1mdv2008.1.i586 and liblm_sensors3-devel-2.10.5-3mdv2008.1.i586
[root@kampret Desktop]# urpmi mysql-devel

ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/libmysql-devel-5.0.51a-8.1mdv2008.1.i586.rpm
installing libmysql-devel-5.0.51a-8.1mdv2008.1.i586.rpm from /var/cache/urpmi/rpms
Preparing… ##########################################################################################
1/1: libmysql-devel ##########################################################################################
[root@kampret Desktop]# urpmi openssl-devel
To satisfy dependencies, the following packages are going to be installed:
Package Version Release Arch
(medium “main_updates”)
libopenssl0.9.8 0.9.8g 4.1mdv2008.1 i586
libopenssl0.9.8-devel 0.9.8g 4.1mdv2008.1 i586
openssl 0.9.8g 4.1mdv2008.1 i586
128B of additional disk space will be used.
2.3MB of packages will be retrieved.
Proceed with the installation of the 3 packages? (Y/n) y

ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/libopenssl0.9.8-0.9.8g-4.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/openssl-0.9.8g-4.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/libopenssl0.9.8-devel-0.9.8g-4.1mdv2008.1.i586.rpm
installing libopenssl0.9.8-0.9.8g-4.1mdv2008.1.i586.rpm openssl-0.9.8g-4.1mdv2008.1.i586.rpm libopenssl0.9.8-devel-0.9.8g-4.1mdv2008.1.i586.rpm from /var/cache/urpmi/rpms
Preparing… ##########################################################################################
1/3: libopenssl0.9.8 ##########################################################################################
2/3: libopenssl0.9.8-devel ##########################################################################################
3/3: openssl ##########################################################################################
———————————————————————-
More information on package openssl-0.9.8g-4.1mdv2008.1.i586

The most significant changes made and starting from the
openssl-0.9.8a-2mdk package is these:

o The OPENSSLDIR has moved from /usr/lib/ssl to /etc/pki/tls

The most significant changes made and starting from the
libopenssl0.9.8-devel-0.9.8a-10mdk package is these:

o The static development libraries (*.a) has been packaged in the
libopenssl0.9.8-static-devel sub package.
o /usr/share/man/man3/buffer.3 has been renamed to /usr/share/man/man3/openssl_buffer.3
to solve a file conflict with rsbac-admin.

———————————————————————-
———————————————————————-
More information on package libopenssl0.9.8-0.9.8g-4.1mdv2008.1.i586

The most significant changes made and starting from the
openssl-0.9.8a-2mdk package is these:

o The OPENSSLDIR has moved from /usr/lib/ssl to /etc/pki/tls

The most significant changes made and starting from the
libopenssl0.9.8-devel-0.9.8a-10mdk package is these:

o The static development libraries (*.a) has been packaged in the
libopenssl0.9.8-static-devel sub package.
o /usr/share/man/man3/buffer.3 has been renamed to /usr/share/man/man3/openssl_buffer.3
to solve a file conflict with rsbac-admin.

———————————————————————-
[root@kampret Desktop]# ls
AdobeReader.desktop* Home.desktop rrdcollect-0.2-1.i386.rpm trash.desktop
cacti-spine-0.8.7a.tar.gz media.desktop subversion-1.5.4.tar.gz
[root@kampret Desktop]# exit
exit
[itmtcon@kampret ~]$ mv Desktop/cacti-spine-0.8.7a.tar.gz /home/itmtcon/pegel_linux/
[itmtcon@kampret ~]$ ls
coba/ Desktop/ Documents/ Download/ Music/ pegel_linux/ Pictures/ scan/ tmp/ Videos/
[itmtcon@kampret ~]$ cd pegel_linux/
[itmtcon@kampret pegel_linux]$ ls
adobe/ netscape-navigator-9.0b2.tar.gz*
cacti-spine-0.8.7a.tar.gz omni1/
dosemu-1.2.2-1.i386.rpm* OOo_3.0.0_LinuxIntel_install_wJRE_en-US.tar.gz*
flash-plugin-9.0.124.0-release.i386.rpm* smb4k-0.9.3-1mdv2008.1.i586_001.rpm*
iP2200_linux_260.tar.gz* thunderbird-2.0.0.17.tar.gz*
[itmtcon@kampret pegel_linux]$ tar zxvf cacti-spine-0.8.7a.tar.gz
cacti-spine-0.8.7a/
cacti-spine-0.8.7a/NEWS
cacti-spine-0.8.7a/LICENSE
cacti-spine-0.8.7a/aclocal.m4
cacti-spine-0.8.7a/php.c
cacti-spine-0.8.7a/php.h
cacti-spine-0.8.7a/sql.c
cacti-spine-0.8.7a/sql.h
cacti-spine-0.8.7a/README
cacti-spine-0.8.7a/README-WINDOWS
cacti-spine-0.8.7a/spine.conf
cacti-spine-0.8.7a/configure
cacti-spine-0.8.7a/libtool
cacti-spine-0.8.7a/LICENSE.LGPL
cacti-spine-0.8.7a/configure.ac
cacti-spine-0.8.7a/poller.c
cacti-spine-0.8.7a/poller.h
cacti-spine-0.8.7a/locks.c
cacti-spine-0.8.7a/locks.h
cacti-spine-0.8.7a/error.c
cacti-spine-0.8.7a/error.h
cacti-spine-0.8.7a/spine.c
cacti-spine-0.8.7a/spine.h
cacti-spine-0.8.7a/config/
cacti-spine-0.8.7a/config/depcomp
cacti-spine-0.8.7a/config/ltmain.sh
cacti-spine-0.8.7a/config/config.h.in~
cacti-spine-0.8.7a/config/config.guess
cacti-spine-0.8.7a/config/install-sh
cacti-spine-0.8.7a/config/config.sub
cacti-spine-0.8.7a/config/missing
cacti-spine-0.8.7a/config/config.h.in
cacti-spine-0.8.7a/config/stamp-h1
cacti-spine-0.8.7a/common.h
cacti-spine-0.8.7a/Makefile.am
cacti-spine-0.8.7a/Makefile.in
cacti-spine-0.8.7a/ping.c
cacti-spine-0.8.7a/ping.h
cacti-spine-0.8.7a/snmp.c
cacti-spine-0.8.7a/snmp.h
cacti-spine-0.8.7a/util.c
cacti-spine-0.8.7a/util.h
cacti-spine-0.8.7a/AUTHORS
cacti-spine-0.8.7a/INSTALL
cacti-spine-0.8.7a/ChangeLog
cacti-spine-0.8.7a/nft_popen.c
cacti-spine-0.8.7a/nft_popen.h
cacti-spine-0.8.7a/COPYING
cacti-spine-0.8.7a/keywords.c
cacti-spine-0.8.7a/keywords.h
[itmtcon@kampret pegel_linux]$ cd c
cacti-spine-0.8.7a/ cacti-spine-0.8.7a.tar.gz
[itmtcon@kampret pegel_linux]$ cd cacti-spine-0.8.7a
[itmtcon@kampret cacti-spine-0.8.7a]$ ls
aclocal.m4 config/ error.c keywords.h locks.c NEWS php.h poller.h snmp.h sql.c
AUTHORS configure* error.h libtool locks.h nft_popen.c ping.c README spine.c sql.h
ChangeLog configure.ac INSTALL LICENSE Makefile.am nft_popen.h ping.h README-WINDOWS spine.conf util.c
common.h COPYING keywords.c LICENSE.LGPL Makefile.in php.c poller.c snmp.c spine.h util.h
[itmtcon@kampret cacti-spine-0.8.7a]$ ./config
config/ configure
[itmtcon@kampret cacti-spine-0.8.7a]$ ./configure
checking build system type… i686-pc-linux-gnu
checking host system type… i686-pc-linux-gnu
checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking for gawk… gawk
checking whether make sets $(MAKE)… yes
checking for gawk… (cached) gawk
checking for gcc… gcc
checking for C compiler default output file name… a.out
checking whether the C compiler works… yes
checking whether we are cross compiling… no
checking for suffix of executables…
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for gcc option to accept ISO C89… none needed
checking for style of include used by make… GNU
checking dependency style of gcc… gcc3
checking how to run the C preprocessor… gcc -E
checking for a BSD-compatible install… /usr/bin/install -c
checking whether ln -s works… yes
checking for a sed that does not truncate output… /bin/sed
checking for grep that handles long lines and -e… /bin/grep
checking for egrep… /bin/grep -E
checking for ld used by gcc… /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld… yes
checking for /usr/bin/ld option to reload object files… -r
checking for BSD-compatible nm… /usr/bin/nm -B
checking how to recognise dependent libraries… pass_all
checking for ANSI C header files… yes
checking for sys/types.h… yes
checking for sys/stat.h… yes
checking for stdlib.h… yes
checking for string.h… yes
checking for memory.h… yes
checking for strings.h… yes
checking for inttypes.h… yes
checking for stdint.h… yes
checking for unistd.h… yes
checking dlfcn.h usability… yes
checking dlfcn.h presence… yes
checking for dlfcn.h… yes
checking for g++… g++
checking whether we are using the GNU C++ compiler… yes
checking whether g++ accepts -g… yes
checking dependency style of g++… gcc3
checking how to run the C++ preprocessor… g++ -E
checking for g77… no
checking for xlf… no
checking for f77… no
checking for frt… no
checking for pgf77… no
checking for cf77… no
checking for fort77… no
checking for fl32… no
checking for af77… no
checking for xlf90… no
checking for f90… no
checking for pgf90… no
checking for pghpf… no
checking for epcf90… no
checking for gfortran… no
checking for g95… no
checking for xlf95… no
checking for f95… no
checking for fort… no
checking for ifort… no
checking for ifc… no
checking for efc… no
checking for pgf95… no
checking for lf95… no
checking for ftn… no
checking whether we are using the GNU Fortran 77 compiler… no
checking whether accepts -g… no
checking the maximum length of command line arguments… 32768
checking command to parse /usr/bin/nm -B output from gcc object… ok
checking for objdir… .libs
checking for ar… ar
checking for ranlib… ranlib
checking for strip… strip
checking for correct ltmain.sh version… no
configure: error:

*** [Gentoo] sanity check failed! ***
*** libtool.m4 and ltmain.sh have a version mismatch! ***
*** (libtool.m4 = 1.5.22, ltmain.sh = 1.5.24) ***

Please run:

libtoolize –copy –force

if appropriate, please contact the maintainer of this
package (or your distribution) for help.

[itmtcon@kampret cacti-spine-0.8.7a]$ make
make: *** No targets specified and no makefile found. Stop.
[itmtcon@kampret cacti-spine-0.8.7a]$ ls
aclocal.m4 config.log error.h LICENSE Makefile.in php.h README spine.conf util.h
AUTHORS configure* INSTALL LICENSE.LGPL NEWS ping.c README-WINDOWS spine.h
ChangeLog configure.ac keywords.c locks.c nft_popen.c ping.h snmp.c sql.c
common.h COPYING keywords.h locks.h nft_popen.h poller.c snmp.h sql.h
config/ error.c libtool Makefile.am php.c poller.h spine.c util.c
[itmtcon@kampret cacti-spine-0.8.7a]$ m
Display all 229 possibilities? (y or n)
[itmtcon@kampret cacti-spine-0.8.7a]$ ma
macptopbm mail-files make_driver_db_lpr makestrs manhole
macroszification mailmail makeindex man manpath
mag mailshar makeinfo man2dvi manweb
mail mailstat makekdewidgets man2html mapscrn
mailfax.sh-postfix mailx makempx mandrakegalaxy.real ma-search-items
mailfax.sh-qmail ma-import makempy mandriva-galaxy ma-search-users
mailfax.sh-sendmail make makeobj mandrivagalaxy.real matteblend.flt
mailfax.sh-smail make_driver_db_cups makepqg mangle mattrib
[itmtcon@kampret cacti-spine-0.8.7a]$ make
make makeindex makempx makepqg
make_driver_db_cups makeinfo makempy makestrs
make_driver_db_lpr makekdewidgets makeobj
[itmtcon@kampret cacti-spine-0.8.7a]$ make
make: *** No targets specified and no makefile found. Stop.
[itmtcon@kampret cacti-spine-0.8.7a]$ pwd
/home/itmtcon/pegel_linux/cacti-spine-0.8.7a
[itmtcon@kampret cacti-spine-0.8.7a]$ ls
aclocal.m4 config.log error.h LICENSE Makefile.in php.h README spine.conf util.h
AUTHORS configure* INSTALL LICENSE.LGPL NEWS ping.c README-WINDOWS spine.h
ChangeLog configure.ac keywords.c locks.c nft_popen.c ping.h snmp.c sql.c
common.h COPYING keywords.h locks.h nft_popen.h poller.c snmp.h sql.h
config/ error.c libtool Makefile.am php.c poller.h spine.c util.c
[itmtcon@kampret cacti-spine-0.8.7a]$ su
Password:
[root@kampret cacti-spine-0.8.7a]# pwd
/home/itmtcon/pegel_linux/cacti-spine-0.8.7a
[root@kampret cacti-spine-0.8.7a]# make
make: *** No targets specified and no makefile found. Stop.
[root@kampret cacti-spine-0.8.7a]# exit
exit
[itmtcon@kampret cacti-spine-0.8.7a]$ make clean
make: *** No rule to make target `clean’. Stop.
[itmtcon@kampret cacti-spine-0.8.7a]$ makeclean
bash: makeclean: command not found
[itmtcon@kampret cacti-spine-0.8.7a]$ su
Password:
[root@kampret cacti-spine-0.8.7a]# urpmi cacti
In order to satisfy the ‘php-gd’ dependency, one of the following packages is needed:
1- php-gd-5.2.5-14.1mdv2008.1.i586: GD extension module for PHP (to install)
2- php-gd-bundled-5.2.5-2mdv2008.1.i586: GD extension module for PHP (to install)
What is your choice? (1-2) 1
To satisfy dependencies, the following packages are going to be installed:
Package Version Release Arch
(medium “Mandriva Linux – 2008.1 (Powerpack) – Installer”)
hping2 2.0.0 0.rc3.4mdv20> i586
php-pear-MDB2 2.5.0b1 1mdv2008.1 noarch
(medium “main”)
libmhash2 0.9.9 5mdv2008.1 i586
libxmlrpc0 0.51 14mdv2008.1 i586
php-pear 5.2.5 4mdv2008.1 noarch
php-pear-Console_ProgressBar 0.2 9mdv2008.1 noarch
php-pear-HTTP_Request 1.4.1 3mdv2008.1 noarch
php-pear-Net_DIME 0.3 9mdv2008.1 noarch
php-pear-Net_POP3 1.3.6 8mdv2008.1 noarch
php-pear-Net_URL 1.0.14 9mdv2008.1 noarch
php-pear-PEAR_Command_Packagi> 0.1.2 2mdv2008.1 noarch
php-pear-PEAR_RemoteInstaller 0.3.1 2mdv2008.1 noarch
php-pear-SOAP 0.10.1 2mdv2008.1 noarch
(medium “main_updates”)
net-snmp 5.4.1 5.2mdv2008.1 i586
net-snmp-mibs 5.4.1 5.2mdv2008.1 i586
net-snmp-utils 5.4.1 5.2mdv2008.1 i586
php-bcmath 5.2.5 14.1mdv2008.1 i586
php-cli 5.2.5 14.1mdv2008.1 i586
php-gd 5.2.5 14.1mdv2008.1 i586
php-mhash 5.2.5 14.1mdv2008.1 i586
php-mysql 5.2.5 14.1mdv2008.1 i586
php-snmp 5.2.5 14.1mdv2008.1 i586
php-xml 5.2.5 14.1mdv2008.1 i586
php-xmlrpc 5.2.5 14.1mdv2008.1 i586
(medium “contrib”)
php-adodb 4.95 1mdv2008.0 noarch
php-pear-Auth 1.5.1 1mdv2008.1 noarch
php-pear-Auth_RADIUS 1.0.5 1mdv2008.1 noarch
php-pear-Crypt_CHAP 1.0.1 1mdv2008.0 noarch
php-pear-File_Passwd 1.1.6 1mdv2008.0 noarch
php-pear-File_SMBPasswd 1.0.2 8mdv2008.1 noarch
php-radius 1.2.5 5mdv2008.1 i586
(medium “contrib_updates”)
cacti 0.8.7b 3mdv2008.1 noarch
14MB of additional disk space will be used.
4.6MB of packages will be retrieved.
Proceed with the installation of the 32 packages? (Y/n) y

ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/php-xml-5.2.5-14.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/php-cli-5.2.5-14.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/php-xmlrpc-5.2.5-14.1mdv2008.1.i586.rpm
installing /var/cache/urpmi/rpms/php-xml-5.2.5-14.1mdv2008.1.i586.rpm
/media/cdrom/i586/media/main/php-pear-5.2.5-4mdv2008.1.noarch.rpm
/media/cdrom/i586/media/main/hping2-2.0.0-0.rc3.4mdv2008.1.i586.rpm
/media/cdrom/i586/media/main/php-pear-MDB2-2.5.0b1-1mdv2008.1.noarch.rpm
/media/cdrom/i586/media/main/libxmlrpc0-0.51-14mdv2008.1.i586.rpm
/media/cdrom/i586/media/main/php-pear-PEAR_RemoteInstaller-0.3.1-2mdv2008.1.noarch.rpm
/media/cdrom/i586/media/main/php-pear-PEAR_Command_Packaging-0.1.2-2mdv2008.1.noarch.rpm
/var/cache/urpmi/rpms/php-cli-5.2.5-14.1mdv2008.1.i586.rpm
/var/cache/urpmi/rpms/php-xmlrpc-5.2.5-14.1mdv2008.1.i586.rpm
Preparing… ##########################################################################################
1/32: php-cli ##########################################################################################
2/32: libxmlrpc0 ##########################################################################################
3/32: php-xmlrpc ##########################################################################################
4/32: hping2 ##########################################################################################
5/32: php-xml ##########################################################################################
6/32: php-pear ##########################################################################################
warning: pear/PEAR requires package “pear/Archive_Tar” (version >= 1.3.1)
warning: pear/PEAR requires package “pear/Console_Getopt” (version >= 1.2)
warning: pear/PEAR requires package “pear/Structures_Graph” (version >= 1.0.2)
pear/PEAR can optionally use package “pear/XML_RPC” (version >= 1.4.0)
pear/PEAR can optionally use package “pear/PEAR_Frontend_Web” (version >= 0.5.0)
pear/PEAR can optionally use package “pear/PEAR_Frontend_Gtk” (version >= 0.4.0)
install ok: channel://pear.php.net/PEAR-1.7.1
install ok: channel://pear.php.net/Archive_Tar-1.3.2
install ok: channel://pear.php.net/Console_Getopt-1.2.3
install ok: channel://pear.php.net/Structures_Graph-1.0.2
install ok: channel://pear.php.net/DB-1.7.13
pear/Log can optionally use package “pear/MDB2” (version >= 2.0.0RC1)
pear/Log can optionally use package “pear/Mail”
pear/Log can optionally use PHP extension “sqlite”
install ok: channel://pear.php.net/Log-1.10.0
pear/Mail can optionally use package “pear/Net_SMTP” (version >= 1.1.0)
install ok: channel://pear.php.net/Mail-1.1.14
warning: pear/Mail_mimeDecode requires package “pear/Mail_Mime” (version >= 1.4.0, excluded versions: 1.4.0)
install ok: channel://pear.php.net/Mail_mimeDecode-1.5.0
install ok: channel://pear.php.net/Mail_Mime-1.5.2
install ok: channel://pear.php.net/Net_Socket-1.0.8
pear/Net_SMTP can optionally use package “pear/Auth_SASL”
install ok: channel://pear.php.net/Net_SMTP-1.2.11
install ok: channel://pear.php.net/XML_Parser-1.2.8
install ok: channel://pear.php.net/XML_RPC-1.5.1
Updating channel “pear.php.net”
Update of Channel “pear.php.net” succeeded
7/32: php-pear-MDB2 ##########################################################################################
install ok: channel://pear.php.net/MDB2-2.5.0b1
MDB2: Optional feature fbsql available (Frontbase SQL driver for MDB2)
MDB2: Optional feature ibase available (Interbase/Firebird driver for MDB2)
MDB2: Optional feature mssql available (MS SQL Server driver for MDB2)
MDB2: Optional feature mysql available (MySQL driver for MDB2)
MDB2: Optional feature mysqli available (MySQLi driver for MDB2)
MDB2: Optional feature oci8 available (Oracle driver for MDB2)
MDB2: Optional feature pgsql available (PostgreSQL driver for MDB2)
MDB2: Optional feature querysim available (Querysim driver for MDB2)
MDB2: Optional feature sqlite available (SQLite2 driver for MDB2)
MDB2: To install optional features use “pear install pear/MDB2#featurename”
8/32: php-pear-PEAR_RemoteInstaller
##########################################################################################
pear/PEAR_RemoteInstaller can optionally use package “pecl/ssh2”
install ok: channel://pear.php.net/PEAR_RemoteInstaller-0.3.1
9/32: php-pear-PEAR_Command_Packaging
##########################################################################################
install ok: channel://pear.php.net/PEAR_Command_Packaging-0.1.2

ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release/php-pear-HTTP_Request-1.4.1-3mdv2008.1.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release/php-pear-SOAP-0.10.1-2mdv2008.1.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release/php-pear-Net_POP3-1.3.6-8mdv2008.1.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release/php-pear-Net_URL-1.0.14-9mdv2008.1.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release/php-pear-Console_ProgressBar-0.2-9mdv2008.1.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/release/php-pear-Net_DIME-0.3-9mdv2008.1.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/php-bcmath-5.2.5-14.1mdv2008.1.i586.rpm
installing /var/cache/urpmi/rpms/php-bcmath-5.2.5-14.1mdv2008.1.i586.rpm
/var/cache/urpmi/rpms/php-pear-Net_POP3-1.3.6-8mdv2008.1.noarch.rpm
/var/cache/urpmi/rpms/php-pear-SOAP-0.10.1-2mdv2008.1.noarch.rpm
/var/cache/urpmi/rpms/php-pear-Console_ProgressBar-0.2-9mdv2008.1.noarch.rpm
/var/cache/urpmi/rpms/php-pear-Net_DIME-0.3-9mdv2008.1.noarch.rpm
/media/cdrom/i586/media/main/libmhash2-0.9.9-5mdv2008.1.i586.rpm
/var/cache/urpmi/rpms/php-pear-HTTP_Request-1.4.1-3mdv2008.1.noarch.rpm
/var/cache/urpmi/rpms/php-pear-Net_URL-1.0.14-9mdv2008.1.noarch.rpm
Preparing… ##########################################################################################
10/32: php-pear-Net_URL ##########################################################################################
install ok: channel://pear.php.net/Net_URL-1.0.14
11/32: php-pear-Net_DIME ##########################################################################################
install ok: channel://pear.php.net/Net_DIME-0.3
12/32: php-pear-Console_ProgressBar
##########################################################################################
install ok: channel://pear.php.net/Console_ProgressBar-0.2
13/32: php-pear-HTTP_Request ##########################################################################################
install ok: channel://pear.php.net/HTTP_Request-1.4.1
14/32: php-pear-Net_POP3 ##########################################################################################
install ok: channel://pear.php.net/Net_POP3-1.3.6
15/32: php-bcmath ##########################################################################################
16/32: php-pear-SOAP ##########################################################################################
install ok: channel://pear.php.net/SOAP-0.10.1
17/32: libmhash2 ##########################################################################################

ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/net-snmp-mibs-5.4.1-5.2mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/php-snmp-5.2.5-14.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/php-mysql-5.2.5-14.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/php-gd-5.2.5-14.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/php-mhash-5.2.5-14.1mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/net-snmp-utils-5.4.1-5.2mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/main/updates/net-snmp-5.4.1-5.2mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/php-pear-Crypt_CHAP-1.0.1-1mdv2008.0.noarch.rpm
installing php-snmp-5.2.5-14.1mdv2008.1.i586.rpm php-pear-Crypt_CHAP-1.0.1-1mdv2008.0.noarch.rpm net-snmp-mibs-5.4.1-5.2mdv2008.1.i586.rpm php-gd-5.2.5-14.1mdv2008.1.i586.rpm php-mysql-5.2.5-14.1mdv2008.1.i586.rpm php-mhash-5.2.5-14.1mdv2008.1.i586.rpm net-snmp-utils-5.4.1-5.2mdv2008.1.i586.rpm net-snmp-5.4.1-5.2mdv2008.1.i586.rpm from /var/cache/urpmi/rpms
Preparing… ##########################################################################################
18/32: net-snmp-mibs ##########################################################################################
19/32: net-snmp-utils ##########################################################################################
20/32: php-snmp ##########################################################################################
21/32: php-pear-Crypt_CHAP ##########################################################################################
pear/Crypt_CHAP can optionally use PHP extension “mhash”
pear/Crypt_CHAP can optionally use PHP extension “mcrypt”
install ok: channel://pear.php.net/Crypt_CHAP-1.0.1
22/32: php-gd ##########################################################################################
23/32: php-mysql ##########################################################################################
24/32: php-mhash ##########################################################################################
25/32: net-snmp ##########################################################################################

ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/php-pear-File_SMBPasswd-1.0.2-8mdv2008.1.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/php-adodb-4.95-1mdv2008.0.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/php-radius-1.2.5-5mdv2008.1.i586.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/php-pear-Auth_RADIUS-1.0.5-1mdv2008.1.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/php-pear-Auth-1.5.1-1mdv2008.1.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/release/php-pear-File_Passwd-1.1.6-1mdv2008.0.noarch.rpm
ftp://ftp.isu.edu.tw/pub/Linux/Mandriva/official/2008.1/i586/media/contrib/updates/cacti-0.8.7b-3mdv2008.1.noarch.rpm
installing php-pear-Auth-1.5.1-1mdv2008.1.noarch.rpm php-pear-Auth_RADIUS-1.0.5-1mdv2008.1.noarch.rpm cacti-0.8.7b-3mdv2008.1.noarch.rpm php-pear-File_SMBPasswd-1.0.2-8mdv2008.1.noarch.rpm php-adodb-4.95-1mdv2008.0.noarch.rpm php-radius-1.2.5-5mdv2008.1.i586.rpm php-pear-File_Passwd-1.1.6-1mdv2008.0.noarch.rpm from /var/cache/urpmi/rpms
Preparing… ##########################################################################################
26/32: php-pear-File_Passwd ##########################################################################################
install ok: channel://pear.php.net/File_Passwd-1.1.6
27/32: php-radius ##########################################################################################
28/32: php-pear-Auth_RADIUS ##########################################################################################
warning: pear/Auth_RADIUS requires package “pear/radius” (version >= 1.2.4)
install ok: channel://pear.php.net/Auth_RADIUS-1.0.5
29/32: php-pear-File_SMBPasswd
##########################################################################################
install ok: channel://pear.php.net/File_SMBPasswd-1.0.2
30/32: php-pear-Auth ##########################################################################################
pear/Auth can optionally use package “pear/MDB”
pear/Auth can optionally use package “pecl/vpopmail” (version >= 0.2)
pear/Auth can optionally use package “pecl/kadm5” (version >= 0.2.3)
pear/Auth can optionally use PHP extension “imap”
pear/Auth can optionally use PHP extension “saprfc”
pear/Auth can optionally use PHP extension “soap”
install ok: channel://pear.php.net/Auth-1.5.1
31/32: php-adodb ##########################################################################################
32/32: cacti ##########################################################################################
[root@kampret cacti-spine-0.8.7a]# /etc/init.d/c
coherence crond cups
[root@kampret cacti-spine-0.8.7a]# /etc/init.d/c


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: